Download ETS 2 mods
» » Passengers Mod 1.4.8 by Linux

Passengers Mod 1.4.8 by Linux

Passengers Mod 1.4.8 by Linux Version game: 1.4.1, 1.4.4, 1.4.5, 1.4.6, 1.4.7, 1.4.8, 1.4.12 Total views: 19 945
Category: Other mods ETS 2
Version Game: 1.4.1, 1.4.4, 1.4.5, 1.4.6, 1.4.7, 1.4.8, 1.4.12
Credits: LiNuX
Submited by: admin

Description about Passengers Mod 1.4.8 by Linux



A Mod Passenger for ETS2, was pretty cool, when using the Bus, you do with him deliveries and charges are passengers. Tested in version 1.4.8.

 

Passengers Mod 1.4.8 by Linux

Passengers Mod 1.4.8 by Linux

Download from our server:
Pasajeros-By-LiNuX-1.4.8.rar [0 b] (downloads: 2779)


Add comment

  • bowtiesmilelaughingblushsmileyrelaxedsmirk
    heart_eyeskissing_heartkissing_closed_eyesflushedrelievedsatisfiedgrin
    winkstuck_out_tongue_winking_eyestuck_out_tongue_closed_eyesgrinningkissingstuck_out_tonguesleeping
    worriedfrowninganguishedopen_mouthgrimacingconfusedhushed
    expressionlessunamusedsweat_smilesweatdisappointed_relievedwearypensive
    disappointedconfoundedfearfulcold_sweatperseverecrysob
    joyastonishedscreamtired_faceangryragetriumph
    sleepyyummasksunglassesdizzy_faceimpsmiling_imp
    neutral_faceno_mouthinnocent

Enter the two words shown in the image:*

  1. John
    • 0
    I can not download it
  2. admin
    • 0
    Quote: John
    I can not download it

    Try to Download from website: Pasajeros-By-LiNuX-1.4.8.rar [773.46 Kb]
    it must to work.

  3. Avery
    • 0
    This mod works, BUT my passengers are stuck in blue container trailers. I'm using ETS2 1.8.2
  4. admin
    • 0
    Quote: Avery
    This mod works, BUT my passengers are stuck in blue container trailers. I'm using ETS2 1.8.2

    What blue container trailers? put a screenshot, i don't understand what you mean

  5. mkdas
    • 0
    I using ets 2 v 1.9.22s but i can;t able to play on any bus mod.what to do cant anyone help plz?i really want to play with volvo 9700....
  6. tacsi68
    • 0
    Quote: mkdas
    I using ets 2 v 1.9.22s but i can;t able to play on any bus mod.what to do cant anyone help plz?i really want to play with volvo 9700....

    This mode works with versions 1.4.1, 1.4.4, 1.4.5, 1.4.6, 1.4.7, 1.4.8, 1.4.12! smile_mini
  7. mkdas
    • 0
    does volvo 9700 mod don;t work one other version?latest update mat release or not?can i play on any other way with this?

News ETS 2 / ATS

Ads